Artifacts Associated With Ticket cdf773248f83d04d

  1. Ticket change [a3ece75589] (rid 2220) by anonymous on 2013-11-13 09:59:08:

    1. foundin initialized to: "0.5.9"
    2. icomment:
      On a Debian 7 (Weezy) machine with Apache 2.4 & PHP 5.4.4
      
      I has not abble to install Garradin because of the following traceback :
      
      > Exception of type ErrorException happened !
      >
      > 0 - strtotime(): It is not safe to rely on the system's timezone settings. You are *required* to use the date.timezone setting or the date_default_timezone_set() function. In case you used any of those methods and you are still getting this warning, you most likely misspelled the timezone identifier. We selected the timezone 'UTC' for now, but please set date.timezone to select your timezone.
      >
      > In: /home/garradin/include/libs/template_lite/class.template.php:110
      >
      > http://garradin.XXXX.org/admin/install.php
      > 
      > #0 [internal function]: Garradin\exception_error_handler(2, 'strtotime(): It...', '/home/garradin/...', 110, Array)
      > #1 /home/garradin/include/libs/template_lite/class.template.php(110): strtotime('2007-01-04 10:3...')
      > #2 /home/garradin/include/lib.template.php(22): Template_Lite->Template_Lite()
      > #3 /home/garradin/include/lib.template.php(13): Garradin\Template->__construct()
      > #4 /home/garradin/include/lib.template.php(40): Garradin\Template::getInstance()
      > #5 /home/garradin/include/init.php(225): require('/home/garradin/...')
      > #6 [internal function]: Garradin\Loader::load('Garradin\Templa...')
      > #7 /home/garradin/www/admin/install.php(62): spl_autoload_call('Garradin\Templa...')
      > #8 {main}
      
      
      This is apparently a PHP security warning since PHP 5.3.
      
      Workarounds:
      
      1) For the user: add a `date.timezone` option in the php.ini file 
      2) For the Garradin code: add `date_default_timezone_set('UTC');` somewhere in the Garradin code (and after replace `UTC` by what may be set in Garradin options)
      
      For now, maybe be just add an entry to recommend to edit php.ini in the commons errors FAQ
      
    3. login: "anonymous"
    4. mimetype: "text/x-fossil-plain"
    5. private_contact initialized to: "b18d721148d5b3122822054aad24c09c64865800"
    6. severity initialized to: "Important"
    7. status initialized to: "Open"
    8. title initialized to: "strtotime() error exception during install"
    9. type initialized to: "Code_Defect"
  2. Ticket change [72af2c2052] (rid 2221) by bohwaz on 2013-11-13 13:57:37:

    1. icomment:
      On Debian, setting date.timezone is not mandatory, as it is read from /etc/localtime.
      
      But the patch was buggy in PHP 5.4.4 and it was corrected in PHP 5.4.6. See [http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=673763#10]
      
      PHP made a big mistake with this warning, the timezone should be read from system time, and not set in php.ini. I'll try to find a way around this strange behaviour in the next release, as it is probably better if the TZ can be defined in the configuration of Garradin, if it differs from the system TZ.
      
      Meanwhile you can get around this by creating a 'config.local.php' file at the root of Garradin with this code:
      
      <?php
      ini_set('date.timezone', 'Australia/Melbourne');
      ?>
      
    2. login: "bohwaz"
    3. mimetype: "text/x-fossil-plain"
    4. priority changed to: "Immediate"
    5. resolution changed to: "Open"
  3. Ticket change [d28b0cc604] (rid 2222) by bohwaz on 2013-11-13 13:58:10:

    1. login: "bohwaz"
    2. mimetype: "text/x-fossil-plain"
    3. status changed to: "Verified"
  4. Ticket change [0a799aba6d] (rid 2641) by bohwaz on 2014-02-07 23:07:51:

    1. icomment:
      RĂ©solu dans [447fcf126adaba93a2b50e13aedadb87478309e3]
      
    2. login: "bohwaz"
    3. mimetype: "text/x-fossil-plain"
    4. resolution changed to: "Fixed"
    5. status changed to: "Fixed"