Overview
Comment:Version minimale de SQLite++
Downloads: Tarball | ZIP archive | SQL archive
Timelines: family | ancestors | descendants | both | dev
Files: files | file ages | folders
SHA1: 2deff92b2c51b57624e77f27c646e696a78d2a3f
User & Date: bohwaz on 2020-04-22 02:17:20
Other Links: branch diff | manifest | tags
Context
2020-04-23
01:11
La colonne bookmark a été supprimée check-in: 6934f3c4a5 user: bohwaz tags: dev
2020-04-22
02:17
Version minimale de SQLite++ check-in: 2deff92b2c user: bohwaz tags: dev
02:17
Widget input select_groups fonctionnel check-in: 53ae33d9ff user: bohwaz tags: dev
Changes

Modified src/include/test_required.php from [6949478384] to [a96dd46521].

47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
    class_exists('SQLite3'),
    'Le module de base de données SQLite3 n\'est pas disponible.'
);

$v = \SQLite3::version();

test_requis(
    version_compare($v['versionString'], '3.7.4', '>='),
    'SQLite3 version 3.7.4 ou supérieur requise. Version installée : ' . $v['versionString']
);

test_requis(
    file_exists(__DIR__ . '/lib/KD2'),
    'Librairie KD2 non disponible.'
);







|
|






47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
    class_exists('SQLite3'),
    'Le module de base de données SQLite3 n\'est pas disponible.'
);

$v = \SQLite3::version();

test_requis(
    version_compare($v['versionString'], '3.16', '>='),
    'SQLite3 version 3.16 ou supérieur requise. Version installée : ' . $v['versionString']
);

test_requis(
    file_exists(__DIR__ . '/lib/KD2'),
    'Librairie KD2 non disponible.'
);